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APLICAȚIE 1. INSTALARE PROGRAME

1.1. Descărcare

1.1.a. gvSIG
Mergeți la pagina de descărcare https://gvsig.org/web/projects/gvsig-desktop/official/

gvsig-1.11/downloads, unde puteți descărca versiunile binare ale programului pentru sistemele de 
operare Windows și Linux. Actuala versiune stabilă a programului este gvSIG 1.11 (24.08.2012). 
La aceeași pagină găsiți link-urile de descărcare a manualului utilizatorului în limbile engleză 
și spaniolă.

1.1.a.1. Windows
Descărcați versiunea All-included - gvSIG-1_11-1305-final-win-i586-withjre-j1_5.exe

1.1.a.2. Linux
Descărcați versiunea All-included - gvSIG-1_11-1305-final-lin-i586-withjre-j1_5.bin
Pentru distribuțiile de Linux care folosesc pachete de tip *.deb, cum ar fi Debian, Ubuntu sau 

Mint etc., puteți utiliza pachetul de instalare de la pagina http://www.gvsig.org/web/plugins/
downloads/debian-releases, selectând între cele două versiuni (i386 și x86_64), în dependență de 
arhitectura sistemului vostru de operare.

Descărcați pachetul gvsig_1.10-1264_i386.deb sau gvsig_1.10-1264_all.deb. 
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1.b. Quantum GIS
Mergeți la pagina de descărcare http://hub.qgis.org/projects/quantum-gis/wiki/Download, 

unde puteți găsi versiunile binare ale programului pentru sistemele de operare Windows, Ma-
cOS X, Android și Linux. Actuala versiune stabilă a programului este Quantum GIS 1.8.0-1 
(24.08.2012).

1.1.b.1. Windows
Pentru sistemul de operare Windows XP/Vista/7 aveți de ales între două opțiuni:
•	 Standalone Installer (recomandat utilizatorilor începători) -  http://qgis.org/downloads/

QGIS-OSGeo4W-1.8.0-1-Setup.exe;
•	 OSGeo4W Installer (recomandat utilizatorilor avansați) - http://download.osgeo.org/

osgeo4w/osgeo4w-setup.exe.
Descărcați versiunea Standalone - QGIS-OSGeo4W-1.8.0-1-Setup.exe
Acest pachet de instalare, pe lângă QGIS, include și o distribuție a softului GRASS GIS (http://

grass.fbk.eu/).

1.1.b.2. Linux
Pentru a instala QGIS pe sistemul de operare Linux (recomandăm distribuțiile Ubuntu Desktop 

12.04 LTS Precise Pangolin (http://www.ubuntu.com/download/desktop) sau Linux Mint 13 Maya 
(http://www.linuxmint.com/download.php) trebuie să adăugați mai întâi depozitele de pachete 
care conțin Quantum GIS și toate dependențele necesare pentru instalare la lista de depozite. 
Acest lucru poate fi realizat din linia de comandă (Terminal) cu comenzile succesive:

•	 sudo apt-get install python-software-properties
•	 sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable
De asemenea, puteți utiliza gestionarul de surse software cu interfață grafică.
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1.2. Instalare

1.2.a. gvSIG

1.2.a.1. Windows
Lansați programul instalabil gvSIG-1_11-1305-final-win-i586-withjre-j1_5.exe și urmați 

instrucțiunile.
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După instalare programul poate fi lansat din meniul Start accesând link-ul gvSIG.

1.2.a.2. Linux
Se recomandă instalarea versiunii *deb a pachetului de instalare pentru ușurința operației. Pen-

tru aceasta lansăm pachetul *.deb (asociat în prealabil cu programul de instalare gdebi) cu dublu-
click. În fereastra care apare apăsăm butonul Instalare pachet.
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Programul poate fi lansat din meniul principal, din grupul de programe Educație.

1.2.b. Quantum GIS

1.2.b.1. Windows
Lansați programul instalabil QGIS-OSGeo4W-1.8.0-1-Setup.exe și urmați instrucțiunile.
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După instalare programul poate fi lansat din meniul Start accesând link-ul Quantum GIS 
Desktop (1.8.0).

1.2.b.2. Linux
Instalarea QGIS în Ubuntu, Debian sau Mint se face din terminal cu comanda:
sudo apt-get update && sudo apt-get install qgis
De asemenea, se poate utiliza managerul de pachete Synaptic pentru a instala Quantum GIS, 

GRASS GIS, SAGA GIS și toate dependențele lor.
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Aplicația poate fi lansată din meniul principal sau din terminal utilizând comanda QGIS.
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1.3. Configurare

1.3.a. gvSIG

Configurarea programului se face prin intermediul ferestrei de preferințe (Prefereces) care poa-
te fi lansată cu butonul .
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Pentru configurare selectați opțiunea pe care doriți să o modificați din arborele din stânga fe-
restrei și veți obține controalele acesteia în spațiul din dreapta ferestrei.

După efectuarea schimbărilor dorite este necesar să reporniți gvSIG, pentru ca noile opțiuni să 
intre în vigoare.

1.3.b. Quantum GIS

Configurarea programului se face prin intermediul ferestrei de opțiuni (care poate fi lansată 
accesând Options din meniul Settings).
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Pentru configurare selectați fila corespunzătoare opțiunii pe care doriți să o modificați și veți 
obține controalele acesteia în spațiul de configurare.
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APLICAȚIE 2. INIȚIERE PROGRAME

2.1. Date utilizate
Pentru realizarea acțiunilor ulterioare este necesar să utilizăm careva date geospațiale. Printre 

altele, vom utiliza trei seturi de date disponibile gratuit pe Internet:
•	 Setul Alaska, disponibil aici: http://download.osgeo.org/qgis/data/qgis_sample_data.zip, 

care conține date în diferite formate, inclusiv în format GRASS GIS. Manualul utilizatorului 
QGIS (http://www.qgis.org/en/documentation/manuals.html) este bazat în special pe acest 
set de date.

•	 Setul de date North Carolina, USA, cu un conținut bogat de date în format vector și ras-
ter, precum și imagini satelitare. Poate fi descărcat aici: http://grass.osgeo.org/sampledata/
nc_spm_latest.tar.gz - în format GRASS, http://grass.osgeo.org/sampledata/north_carolina/
nc_shape.tar.gz - date vector (format ESRI Shapefile) și http://grass.osgeo.org/sampledata/
north_carolina/nc_rast_geotiff.tar.gz - date raster (GeoTIFF).

•	 Setul de date DIVA-GIS (http://www.diva-gis.org/gdata), disponibil pentru download pen-
tru diferite țări.

2.2. Lansare program
Lansați programul și faceți observații asupra interfeței programului (ferestre, meniuri, bare de 

instrumente, bară de stare etc.)
La pornirea programului veți obține un proiect nou fără a avea careva date încărcate.

2.3. Interfața grafică (GUI)

2.3.a gvSIG
gvSIG lucrează cu 3 tipuri de documente: Vedere/Afișare (View), Tabel (Table) și Hartă (Map). 

Acestea pot fi create și gestionate din Project manager.

Interfața gvSIG după lansare Interfața Quantum GIS după lansare
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Pentru a crea o vedere nouă facem click pe pictograma View apoi pe butonul New. În lista de 
documente View găsim acum documentul Untitled – 0. Un proiect gvSIG poate conține mai mul-
te Vederi, Tabele și Hărți.

Pentru a modifica denumirea sau proprietățile Vederii create, pentru a o deschide sau șterge, 
utilizăm butoanele din dreapta ferestrei Managerului de proiecte.

Apăsați butonul Properties. Dacă acesta nu este activ, probabil nu ați selectat nici un View din 
listă.
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Dați click pe butonul Proiecție curentă (Current projection). Aceasta va deschide dialogul Sis-
tem de referință spațială (Spatial Reference System).

Utilizând lista derulantă Type, selectați EPSG (European Petroleum Survey Group, http://www.
epsg.org/). Introduceți codul EPSG=32635 (corespunde sistemului de proiecție WGS 84 / UTM 
zone 35N) și apăsați Caută (Search). Selectați Ok. Selectați Ok repetat în fereasta View properties.

Pentru a deschide Vederea creată apăsați butonul Open. Fereastra Vederii este formată din 3 
zone: Legenda / Table of Contents în partea de sus-stânga, Vedere de ansamblu în partea de jos-
stânga și Zona de afișare în dreapta.
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2.3.b QGIS
Interfața QGIS este reprezentată de o interfață unică, în care se deschid toate tipurile de docu-

mente. 

Elementele principale ale interfeței grafice QGIS sunt:
•	 Bara de meniuri - oferă acces la diferite caracteristici QGIS utilizând un meniu ierarhic 

standard.
•	 Barele de unelte - oferă acces la majoritatea funcțiilor disponibile din meniuri, plus instru-

mente adiționale pentru interacțiunea cu harta.
•	 Legenda - listează toate stratele din proiect. Casetele de selectare pot fi utilizate pentru a afișa 

sau ascunde stratele de hartă. Un strat poate fi selectat și tractat sus-jos pentru ai schimba 
ordinea. Stratele aflate într-o poziție superioară în legendă vor fi afișate deasupra altor strate 
în zona de afișare.

•	 Spațiul de lucru - în acest spațiu sunt afișate stratele de hartă. Spațiul de lucru (Vedere/
Afișare - View) poate fi deplasat și focusat. În acest sens se utilizează instrumentele specifice 
din meniul View sau din bara de unelte Navigare Hartă (Map Navigation).

•	 Bara de stare - vă arată poziția curentă în coordonatele hărții (metri sau grade decimale) la 
locația mausului, scara hărții, proiecția curentă a proiectului etc. De asemenea, aici veți citi 
informații despre progresul de încărcare a stratelor de hartă și despre existența de actualizări 
a extensiilor instalate, etc.
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2.4. Proiecte GIS
Atât gvSIG cât și QGIS stochează informația privind datele încărcate, setările, modul de vizu-

alizare a acestora, proiecția curentă în așa-numitele proiecte. În gvSIG proiectele pot fi salvate ca 
fișiere având extensia *.gvp, iar în Quantum GIS *.qgs. Salvarea proiectelor este binevenită, deoa-
rece ne scutește de lucru suplimentar de fiecare dată când revenim asupra lucrului pentru diverse 
manipulări. Proiectele pot fi salvate astfel:

2.4.a gvSIG
File→Save as…
În fereastra apărută alegem locația în care va fi salvat fișierul proiect și denumirea acestuia.

2.4.b QGIS
File→Save Project As…
În fereastra apărută alegem locația în care va fi salvat fișierul proiect și denumirea acestuia.
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2.5. Lucrul cu barele de instrumente

2.5.a gvSIG
Accesați meniul Show→Toolbars. Veți vedea o listă de bare de instrumente; aceasta poate fi di-

ferită în dependență de numărul de extensii instalate și tipul de documente activ în momentul dat. 
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Debifați barele pe rând. Veți observa că numărul de instrumente din „bara instrumentelor” s-a 
micșorat.
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2.5.b QGIS
Dați click-dreapta pe spațiul liber din bara de instrumente. Veți observa o listă de bare de in-

strumente disponibile; aceasta poate fi diferită în dependență de numărul de extensii instalate. 
Debifați toate barele cu excepția: Layers, Manage Layers și Map Navigation.

																							

Veți observa că numărul de instrumente din „bara instrumentelor” s-a micșorat.
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Dați click-stânga pe marginea din stânga a bare de instrumente și deplasați fără a elibera buto-
nul mausului. Veți observa că bara se deplasează și poate fi poziționată în alt loc.

2.6. Încărcarea datelor vector

2.6.a gvSIG
Pentru a încărca un strat vectorial trebuie mai întâi să intrăm în posesia acestuia. Aici vom uti-

liza setul de date DIVA-GIS pentru Republica Moldova. Datele descărcate în format *.zip trebuie 
dezarhivate mai întâi. 

gvSIG este capabil să încarce direct, fără importare un număr mare de formate vector și raster. 
De altfel, gvSIG, ca și QGIS nu dispun de formate proprii pentru fișierele vector și raster, ci utili-
zează formate consacrate cum ar fi ESRI Shapefile pentru vectori și GeoTIFF pentru rastere.

Pentru a încărca un strat vector accesați butonul . Acesta va deschide dialogul Add layer…
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Acesta oferă posibilitatea de a selecta între diferite formate de date geospațiale, inclusiv date 
bazate pe fișier, baze de date geospațiale și date oferite de servere de date prin diverse protocoale.

Pentru a încărca un strat de date în format *.shp selectăm fila File în partea de sus a ferestrei de 
dialog și apăsăm butonul Add.

În fereastra de navigare apărută ne deplasăm spre directoriul unde sunt stocate datele noastre. 
Selectăm tipul de fișiere pe care dorim să-l încărcăm (Files of Type), alegem gvSIG shp driver. 
Selectăm fișierul MDA_adm1.shp și apăsăm butonul Open. Putem încărca concomitent mai mul-
te date, pentru aceasta folosim butoanele Shift și Ctrl. În fereastra de dialog Add layer… putem 
ajusta și proiecția curentă în dependență de datele utilizate, zona de acoperire și utilizarea curentă 
a hărții. Faceți click pe butonul …

Setați proiecția EPSG=4326.
Apăsați butonul Ok.
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2.6.b QGIS
Dați click pe butonul . QGIS poate manipula direct, fără importare, diverse formate vector și 

raster, datorită funcționalității bibliotecii GDAL/OGR (http://www.gdal.org/). Spre deosebire de 
gvSIG, în QGIS adăugarea de strate vector sau raster se face accesând butoane diferite.

Ca și gvSIG, QGIS poate lucra cu date vector stocate ca și fișiere, seturi de fișiere, baze de date 
geospațiale sau pe servere la distanță. Pentru a încărca un strat vector de tip *.shp selectăm ca sur-
să opțiunea File. De asemenea, selectăm codificarea caracterelor (Encoding) pentru fișierele încăr-
cate (*.dbf) prin intermediul meniului derulant (dacă nu sunteți sigur, alegeți opțiunea System).

Apăsați butonul Răsfoiește (Browse) pentru a naviga până la locația fișierului *.shp.
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Selectați tipul de fișier din meniul derulabil.

Selectați fișierul MDA_adm1.shp și apăsați butonul Open. În dialogul Add vector layer apăsați 
butonul Open.
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2.7. Încărcarea datelor raster

2.7.a gvSIG
Aici vom utiliza setul de date North Carolina. Datele descărcate în format *.zip trebuie dezar-

hivate mai întâi. 
Pentru a încărca un strat raster accesați butonul . Acesta va deschide dialogul Add layer…
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Pentru a încărca un strat de date în format *.tif selectăm fila File în partea de sus a ferestrei de 
dialog și apăsăm butonul Add.

În fereastra de navigare apărută ne deplasăm către directoriul unde sunt stocate datele noastre. 
Selectăm tipul de fișiere pe care dorim să-l încărcăm (Files of Type), alegem gvSIG Raster Driver. 
Selectăm fișierul elevation.tif și apăsăm butonul Open. Putem încărca concomitent mai multe 
date, pentru aceasta folosim butoanele Shift și Ctrl.

Fereastra de dialog apărută (în cazul când fișierul adăugat și vederea curentă au proiecții dife-
rite) ne va solicita să alegem din cele 4 opțiuni. Alegeți opțiunea Schimbă proiecția Vederii pentru 
a se potrivi cu cea a rasterului (Change the view projection to raster projection) și apăsați Accept.

 În fereastra de dialog Add layer… apăsați butonul Ok.
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2.7.b QGIS
Dați click pe butonul  din bara de instrumente Manage Layers.

Selectați tipul de fișier din meniul derulabil.
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Selectați fișierul elevation.tif și apăsați butonul Open.

2.8. Pan, Zoom, Măsurători, Informații

2.8.a gvSIG
Pentru a redimensiona sau deplasa imaginea afișată (respectiv a modifica scara de vizualizare a 

hărții) utilizăm butoanele din bara de unelte sau meniul View→Navigation.

De asemenea, scara hărții poate fi modificată din bara de stare, setând din cele predefinite.
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Pentru realizarea măsurărilor de distanțe și arii pe harta afișată utilizăm butoanele corespunză-
toare din bara de instrumente:  - pentru distanțe și  - pentru suprafețe.

Pentru măsurarea distanței, activăm butonul , facem click în punctul de pornire pe hartă, 
mutăm cursorul spre următorul punct, și continuăm pe parcurs facem click ș.a.m.d.

În bara de stare putem citi informații despre: scara hărții, coordonatele cursorului, lungimea 
parțială a segmentului curent, lungimea totală a liniei și sistemul de proiecție curentă.

Pentru măsurarea ariei suprafeței, activăm butonul riglă ( ), facem click în punctul de pornire 
pe hartă, mutăm cursorul spre următorul punct de pe parcurs, facem click ș.a.m.d.
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În bara de stare putem citi informații despre: scara hărții, coordonatele cursorului, perimetrul 
poligonului, aria suprafeței cu unitatea de măsură și sistemul de proiecție curentă.

Printre interogările simple se găsesc și citirile de informații de pe stratele de hartă afișate și ac-
tive curent. În acest sens, activați butonul Informații (Information)  și dați click pe celula raster 
asupra căreia vrem să găsim informații. Aceasta va deschide fereastra cu rezultatele interogării, în 
care putem citi informații despre coordonatele punctului și valorile asociate celulei intersectate.

2.8.b QGIS
Pentru a redimensiona sau deplasa imaginea afișată (respectiv a modifica scara de vizualizare a 

hărții) utilizăm butoanele din bara de unelte Map Navigation sau meniul View.
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De asemenea, scara hărții poate fi modificată din bara de stare, setând din cele predefinite.

Pentru realizarea măsurărilor de distanțe și arii pe harta afișată utilizăm butoanele corespunză-
toare din bara de instrumente:  - pentru distanțe,  - pentru suprafețe și  - pentru unghiuri.

Pentru măsurarea distanței, activăm butonul , facem click în punctul de pornire pe hartă, 
mutăm cursorul spre următorul punct și pe parcurs facem click ș.a.m.d.

În fereastra deschisă automat putem citi informații despre: lungimea parțială a segmentului 
curent și lungimea totală a liniei.

Pentru măsurarea ariei suprafeței, activăm butonul , facem click în punctul de pornire pe 
hartă, mutăm cursorul spre următorul punct, și pe parcurs facem click ș.a.m.d.
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În fereastra deschisă automat putem citi informații despre: aria suprafeței poligonului descris 
cu unitatea de măsură utilizată.

Printre interogările simple se găsesc și citirile de informații de pe stratele de hartă afișate și ac-
tive curent. În acest sens, activați butonul Identify Features  și dați click pe celula raster care ne 
interesează ca să găsim informații. Aceasta va deschide fereastra cu rezultatele interogării, în care 
putem citi informații despre valoarea asociată celulei intersectate.
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APLICAȚIE 3. SIMBOLIZAREA DATELOR VECTOR ȘI RASTER

3.1. Proprietăți date vector

3.1.a gvSIG
Dialogul Proprietăți Strat (Layer Properties) pentru vectori oferă informații despre strat, setări 

de simbologie și opțiuni de etichetare. Pentru a accesa dialogul Layer Properties dați click-dreapta 
pe strat în legendă și selectați Properties… din meniul pop-up.

Fereastra Layer Properties este formată din o serie de file, care grupează diverse caracteristici 
referitoare la stratele vector.

Modul de simbolizare a datelor vector poate fi setat din fila Symbology. Pentru simbolizarea 
diferitor elemente de hartă se pot crea simboluri particularizate. Pentru aceasta utilizăm butonul 
Change symbol…, care va deschide fereastra Symbol selection.
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Folosind controalele acesteia modificăm tipul de simbol, tipul de linie, culoarea și grosimea 
liniei etc. După setare, apăsăm butonul Ok și revenim la fila Simbology. Aici, de asemenea, putem 
salva stilul creat pentru a fi utilizat ulterior sau încărca unul dintr-un fișier.

3.1.b QGIS
Dialogul Proprietăți Strat (Layer Properties) pentru vectori oferă informații despre strat, setări 

de simbologie și opțiuni de etichetare. Pentru a accesa dialogul Layer Properties dați click-dreapta 
pe strat în legendă și selectați Properties din meniul pop-up.

Fereastra Layer Properties este formată din o serie de file, care grupează diverse caracteristici 
referitoare la stratele vector.
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Modul de simbolizare a datelor vector poate fi setat din fila Style. În QGIS există două sisteme 
de simbolizare, vechi și nou, care se pot interschimba cu butonul Old simbology – New simbology. 
Noi vom folosi simbologia de tip nou, care este predefinită (butonul trebuie să fie etichetat cu Old 
simbology!).

Pentru simbolizarea diferitor elemente de hartă pot fi folosite stiluri predefinite/salvate, pe care 
le putem selecta din partea de jos a filei Style. De asemenea, se pot crea simboluri noi, particulari-
zate. Pentru aceasta utilizăm butonul Change, care va deschide fereastra Symbol properties.

Folosind controalele acesteia modificăm tipul de simbol, tipul de linie, culoarea și grosimea 
liniei, stilul unirii și modul de rotunjire a capetelor. După setare apăsăm butonul Ok și revenim 
la fila Style. Aici, de asemenea, putem defini transparența pentru strat și putem salva stilul creat 
pentru a fi utilizat ulterior.
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3.2. Proprietăți date raster

3.2.a gvSIG
Dialogul Proprietăți Strat (Layer Properties) pentru rastere oferă informații despre strat, setări 

de simbologie și opțiuni de transparență. Pentru a accesa dialogul Layer Properties dați click-
dreapta pe strat în legendă și selectați Properties din meniul pop-up.

Aceasta va deschide fereastra Raster properties, care vă oferă informații despre raster, vă per-
mite să modificați transparența, să îmbunătățiți luminozitatea și contrastul rasterului afișat, să 
recalculați statisticile rasterului sau să setați intervalul de scară la care va fi afișat.
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3.2.b QGIS
Dialogul Proprietăți Strat (Layer Properties) pentru rastere oferă informații despre strat, setări 

de simbologie, opțiuni de transparență etc. Pentru a accesa dialogul Layer Properties dați click-
dreapta pe strat în legendă și selectați Properties din meniul pop-up.

3.3. Simbolizare date vector

3.3.a gvSIG
1. Lansați gvSIG accesând Start→All Programs→Gva→gvSIG→gvSIG.
2. În gvSIG, accesați butonul Add layer… →Add. Navigați la directoriul care conține date, 

selectați fișierul boundary_county.shp și dați click pe Open. Click Ok.
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4. Dați click pe boxa stratului din legendă, bifând și debifând, puteți observa că această acțiune 
face stratul vizibil sau invizibil.

5. Modificați modul de afișare a poligoanelor ca și contururi fără umplere cu linie continuă de 
0,25 puncte de culoare roșie. Click-dreapta→Properties→Symbols→Choose symbol…. Modificați 
în fereastra Symbol selection după cum urmează și dați OK. 

Apăsați Apply și Close. Rezultatul trebuie să arate așa…
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6. În operația anterioară am utilizat modul de simbolizare Simbol unic (Single symbol), când 
toate elementele stratului sunt reprezentate la fel. gvSIG permite utilizarea și a altor moduri de 
reprezentare. Le puteți accesa din stânga filei Symbols.

Dați click-dreapta→Properties→Symbols. Selectați opțiunea Unique values din grupul Catego-
ries. 

Modificați: Classification field la NAME și Color ramp la purple-red+stripes, apăsați Add all, 
apoi Apply și Accept. Rezultatul trebuie să arate așa…
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7. Dați click-dreapta→Properties→Symbols. Modificați tipul de simbolizare la Quantity by cate-
gory din grupul Multiple attributes. Setați în Fields of values la Color field AREA. Apăsați butonul 
Color ramp.

La classification field setați AREA, la Inteval type setați Equal intervals, la Number of intervals 
setați 5. Apăsați butonul Compute intervals, apăsați butonul Ok.
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Apăsați Apply și Accept. Rezultatul trebuie să arate cam așa…
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3.3.b QGIS
1. Lansați QGIS accesând Start→All Programs→Quantum GIS Lisboa→Quantum GIS Desktop 

(1.8.0).
2. În QGIS, accesați Layer→Add Vector Layer sau dați click pe butonul Add Vector Layer .
3. Dați click pe butonul Browse, apoi navigați la directoriul care conține date, selectați fișierul 

boundary_county.shp și dați click pe Open. Open.

   

4. Dați click pe boxa stratului din legendă, bifând și debifând, puteți observa că această acțiune 
face stratul vizibil sau invizibil.

5. Modificați modul de afișare a poligoanelor ca și contururi fără umplere cu linie continuă 
de 0,25 puncte de culoare roșie. Click-dreapta→Properties→Style→Change. Modificați în fereastra 
Symbol properties după cum urmează și dați OK. OK.

Rezultatul trebuie să arate așa…
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6. În operația anterioară am utilizat modul de simbolizare Simbol unic (Single simbol), când 
toate elementele stratului sunt reprezentate la fel. QGIS permite utilizarea și a altor moduri de 
reprezentare. Le puteți accesa din meniul desfășurabil din sus-stânga a filei Style.

Dați click-dreapta→Properties→Style. Modificați tipul de simbolizare la Categorized. Modificați 
în fila Style: Column la NAME și Color ramp la RdYlGn, apăsați Classify apoi OK.
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Rezultatul trebuie să arate așa…

7. Dați click-dreapta→Properties→Style. Modificați tipul de simbolizare la Graduated. Modificați 
în fila Style: Column la AREA, Color ramp la BrBG, inserați 5 ca număr de clase (Classes), alegeți 
Pretty Breaks pentru modul de grupare (Mode) , apăsați Classify apoi OK.
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Rezultatul trebuie să arate cam așa…

3.4. Simbolizare date raster

3.4.a gvSIG
Modificarea modului de afișare (tabelei de culori) a rasterului procedăm astfel.

În Generic Toolbar Panel dați un click îndelungat pe butonul 1 din stânga barei, până când 
apare meniul desfășurabil, din care selectați opțiunea Raster layer.

În Generic Toolbar Panel dați un click îndelungat pe butonul 2 din stânga barei, până când 
apare meniul desfășurabil, din care selectați opțiunea Color table.
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Aceasta va deschide fereastra Color table.

Utilizând controalele acestei ferestre puteți modifica tabelul de culori curent, crea unul nou sau 
selecta un tabel preexistent.

3.4.b QGIS
Modificarea simbologiei imaginii se realizează din fila Style, de unde se pot alege între mai 

multe opțiuni de simbolizare; pentru rastere cu o bandă sau trei benzi, utilizând diverse tabele de 
culori.
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APLICAȚIE 4. GEOREFERENȚIEREA UNUI RASTER

4.1. QGIS. Plugin-ul Georeferencer
Georeferențierea în QGIS se face cu ajutorul extensiei (plug-in) Georeferencer. Pentru înce-

put, încărcați în proiectul curent stratul vectorial de reper, reprezentat prin caroiajul foilor de 
hartă topografică la scara 1:50.000, având sistemul de proiecție EPSG:28465 (Pulkovo_1942_GK_
Zone_5N).

Lansați fereastra plugin-ului din meniul Raster→Georeferencer→Georeferencer.
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Fereastra plugin-ului este divizată în două părți. În spațiul de sus este afișat rasterul de 
georeferențiat, iar în cel de jos sunt afișate coordonatele punctelor de control.

Dați click pe butonul Open raster .
Navigați către directoriul unde aveți stocată imaginea raster. În dialogul următor veți fi întrebat 

să alegeți sistemul de coordonate a rasterului (CRS). Aceasta este proiecția punctelor de control. 

Selectați sistemul de coordonate și apăsați OK; imaginea va fi afișată în fereastra Georeferencer.
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4.2. Adăugarea de puncte de control
Pentru navigare utilizați instrumentele Zoom și Pan. Pentru inserarea de coordonate vom uti-

liza colțurile cadrului hărții, în care vom plasa câte un punct de control.
Navigăm la colțul cadrului hărții, activăm butonul Addpoint  și plasăm un punct de control 

pe colțul hărții. Aceasta va deschide fereastraEntermapcoordinates.

Dacă cunoașteți coordonatele reale ale punctului, le inserați în casetele X și Y, după care apăsați 
OK (este cazul când avem datele colectate din teren sau de pe planșa de hartă, deci când nu utili-
zăm o imagine de reper).

În cazul nostru, avem situația din urmă, deci vom apăsa butonul Frommapcanvas. Aceasta va 
activa cadrul hărții, unde faceți click pe punctul corespunzător de pe vectorul caroiaj utilizat ca 
reper.
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Coordonatele reale de pe stratul georeferențiat vor fi citite și inserate automat în casetele feres-
trei Entermapcoordinates.

Dați click pe OK. Observați acum în spațiul de jos a ferestrei georeferențiatorului un rând în 
care sunt înscrise coordonatele punctului pe raster și în teren.
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Repetați procedeul până când veți avea câte un punct pentru fiecare colț al cadrului hărții.



62 INIȚIERE ÎN SIG
Ghid metodic

4.3. Transformarea
Acum accesați Settings→Transformation Settings. În dialogul Transformation settings trebuie 

să selectați mai mulți parametri ai transformării la care va fi supus rasterul. Setați ca și în imaginea 
de mai jos, corectând directoriul de salvare a fișierului raster rezultat (Output raster).

Apăsați butonul OK.Acum vă rămâne doar să rulați procesul de transformare apăsând buto-
nul Start georeferencing  . Odată procesul terminat, puteți adăuga noul raster georeferențiat la 
proiectul curent.
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APLICAȚIE 5. IMPORT / EXPORT VECTORI

5.1. Import fișier *.csv
CSV (din engleză Comma-Separated Values - Valori separate prin virgulă) - format text fo-

losit pentru stocarea de date tabelare. Fiecare linie a fișierului - este o linie a tabelului. Valorile 
coloanelor individuale sunt separate printr-un caracter delimitator - o virgulă. Cu toate acestea, 
majoritatea programelor interpretează liber standardele CSV și permit utilizarea altor simboluri 
ca separator (ex. punct și virgulă, două puncte, Spațiu, Tab). Fișierele CSV sunt utilizate pentru 
stocarea datelor geospațiale (seturi de puncte care posedă coordonatele X și Y). Sunt deseori utili-
zate pentru transferul de date către alte programe (mai ales non-GIS).

Figură 1: Fișier .csv deschis cu un editor de text

Figură 2: Fișier .csv deschis cu LibreOffice Calc
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5.1.a gvSIG
Pentru această operație avem nevoie de extensia Normalization, care poate fi instalată utilizând 

Add-ons manager.

Selectați Installation from URL. Modificați adresa predefinită cu http://downloads.gvsig.org/
download/gvsig-desktop/dists/1.11.0/packages.gvspki

Next.

Bifați org.gvsig.normalization. Next. Restartați programul. După lansare în meniul Table devi-
ne disponibil instrumentul Normalize text file.

Lansați instrumentul.
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Navigați la fișierul .csv. Apăsați Open. În fereastra meniului setați după cum urmează.

Adăugați câmpurile X, Y și Z din câmpul New fields, accesând butonul . Configurați fiecare 
câmp în parte, alegând Field name, Field type, Field delimiters și apăsați Test run. Rezultatul se 
vede în spațiul Sample output. Dacă rezultatul este satisfăcător, apăsați Run. În fereastra New table 
selectați numele și locația de salvare pentru fișierul. dbf rezutat.

Încărcați noul fișier .dbf, utilizând dialogul New table din Project manager.
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Utilizând butonul Add points from table...  convertim fișierul .dbf (cu coordonatele X, Y).

Exportăm stratul nou de puncte ca Shapefile.
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5.1.b QGIS

Accesăm Layer→Add Delimited Text Layer.

Configurați după cum urmează.

Apăsați OK. Selectați proiecția. OK
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Salvați datele ca shapefile, click-dreapta, Save As...

5.2. Import fișiere *.dxf

5.2.a gvSIG

Pot fi deschise direct, utilizând gvSIG DXF Memory Driver. Add layer...
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5.2.b QGIS
Pot fi deschise direct, utilizând biblioteca GDAL/OGR. Add vector layer.

5.3. Import fișiere *.gpx

5.3.a gvSIG
Pentru a încărca fișiere *.gpx (GPS eXchange Format) este necesar să instalăm extensia extGPX 

(http://www.gvsig.org/web/plugins/downloads/extgpx).
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Accesați link-ul Get extGPX for All Platforms. Dezarhivați. Copiați în directoriul C:\Program 
Files\gvSIG_1.11.0_final\bin\gvSIG\extensiones de pe calculatorul vostru. Lansați gvSIG.

Add layer...

5.3.b QGIS
Pot fi deschise direct, utilizând biblioteca GDAL/OGR. Add vector layer.

5.4. Export Vector la Raster

5.4.a gvSIG
Încărcați setul de date vector1.shp.
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Pentru conversie vom utiliza extensia SEXTANTE . SEXTANTE→Algorithms→Rasterizatio 
and interpolation→Rasterize vector layer. Setați opțiunile de intrare și ieșire din cele două file ale 
ferestrei Rasterize vector layer.
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Apăsați butonul OK. Rasterul rezultat încărcat va arăta așa.

5.4.b QGIS
Încărcați setul de date vector1.shp.
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Pentru conversie vom utiliza extensia GdalTools (Meniul Raster). Raster→Conversion→Rasterize 
(Vector to raster)

Configurați, după cum urmează. Setați: Input file, Attribute fild, Output file, New size.

OK. Rasterul rezultat încărcat va arăta așa.
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5.5. Export Raster la Vector

5.5.a gvSIG

Încărcați rasterul raster1.tif.

Pentru conversie vom utiliza extensia SEXTANTE . SEXTANTE→Algorithms→Vectorizati
on→Vectorize raster layer (polygons). Setați opțiunile de intrare și ieșire din fereastra Vectorize 
raster layer (polygons).

OK. Vectorul rezultat încărcat va arăta așa.
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5.5.b QGIS
Încărcați rasterul raster1.tif.
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Pentru conversie vom utiliza extensia GdalTools. Raster→Conversion→Polygonize (Raster to 
vector)

Configurați, după cum urmează. Setați: Input file, Output file, Fild name.

OK. Vectorul rezultat încărcat va arăta așa.
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APLICAȚIE 6. DIGITIZAREA ȘI EDITAREA DATELOR

6.1. Editarea în gvSIG

6.1.1 Introducere
gvSIG sprijină editarea elementelor spațiale în mai multe formate, inclusiv ESRI Shapefile și 

straturi PostGIS.

6.1.2. Crearea unui nou set de date vectorial în format ESRI Shapefile
Pentru a crea un set de date shapefile: View→Newlayer→Shapefil…

Introducem un nume pentru strat și alegem opțiunea Polygon la Geometrytype. Next.
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Apăsăm butonul Addfield. În spațiul Definefieldsdați dublu click în celulele pentru Field, Type și 
Length și introducem la Id, Integer și 5. Apăsăm iarăși butonul Addfield. În spațiul Definefieldsdați 
dublu click în celulele pentru Field, Type și Length și introducem la Nume, String și 25.Next.

Alegeți calea de salvare și numele noului set de date, precum și sistemul de coordonate a aces-
tuia (Currentprojection: EPSG:28465).Finish. Vectorul nou este creat și încărcat automat în View-
ulcurrent, însă nu conține careva elemente.

6.1.3. Digitizarea unui poligon
Scopul nostru este de a digitiza unele obiecte din rasterul L-35-07-V_modified.tif. Încărcăm 

acest raster ca imagine de fundal, de pe care vom citi datele pentru digitizare.Stratul nou creat a 
fost încărcat în stare de editare, deci putem începe crearea de noi elemente.Dacă folosim un vec-
tor needitat, dați click dreapta pe vector în legendă și din meniul contextual alegem Start editing. 
Aceasta va activa stratul pentru modificări și va deschide fereastra cu coordonatele punctelor in-
serate în partea de jos a View-ului. O puteți ascunde dând click pe săgeata orientată în jos.
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Înainte de a începe editarea, trebuie să ne asigurăm că bara de instrumente este vizibilă. Dacă 
nu, accesăm Show→Toolbars și bifăm Insert și Modify.

Să începem digitizarea:
1). Mărim o zonă din hartă în care există un lac.
2). Dacă nu suntem deja în modul Editare, facem click pe instrumentul Startediting.
3). Facem click pe butonul Polyline  aflat pe bara de instrumente de digitizare.
4). Pentru a digitiza, facem click cu butonul stânga al mouse-ului și începem mișcarea de-a lungul 

liniei țărmului lacului. Facem clic la fiecare locație în care există o schimbare de direcție.

5). Dacă ajungem la marginea hărții și trebuie să vedeți mai mult din obiectul digitizat, comutați 
la instrumentul Pan, deplasați vederea, reveniți la butonul Polyline și continuați digitizarea.

6). Dacă în timpul digitizării trebuie să mărim sau să micșorăm utilizați rotița mouse-ului.
7). Pentru a termina editarea lacului, efectuăm click-dreapta la punctul final și accesăm Finish sau 

dați dublu-click.Pentru a introduce valorile atributelor definite (Id, Nume), accesați butonul 
Show attribute table of active layer . În tabelul deschis introduceți un număr de identificare 
și un nume pentru lac.
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8. Pentru a salva modificările trebuie să oprim editarea, făcând clic-dreapta→ Stop editing din 
bara de instrumente. O casetă de dialog apare și alegem Yes pentru a salva editările.

Lacul acum apare ca un poligon regulat și îl putem identifica și să-i vizualizăm atributele. Puteți 
continua digitizarea folosind instrumentul Startediting.

6.1.4. Editarea caracteristicilor
Instrumentele folosite pentru digitizare se afla în bara de instrumente de digitizare și digitizare 

avansată și permit de adăugat, de șters și de mutat vertecși pentru a modifica un obiect.

De la stânga la dreapta, instrumentele sunt:

Setarea toleranței snap
Înainte de a putea edita vertecși, avem nevoie de a seta toleranța de captare (snap). Aceasta este 

distanța pe care gvSIG o utilizează pentru a „căuta” vertecși pe care încercăm să îi edităm atunci 
când facem click pe hartă. Dacă nu suntem în parametrii toleranței snapgvSIG nu va găsi și selec-
ta vertecși pentru editare. Toleranța este stabilită în unitatea de măsură a hărții. Dacă specificăm 
o toleranță prea mare, QGIS poate sări la un vertex greșit, mai ales dacă sunt un număr mare de 
vertecși în imediata apropiere.

Pentru a stabili toleranța de captare, accesăm Editing settings… din fereastra pop-up care apare 
după ce dați click dreapta pe strat în legendă. Selectați stratul afectat de snapping și toleranța la 
snapping în pixeli.

Editarea vertecșilor
Odată ce toleranța este stabilită, putem muta vertecși pentru a corecta greșelile, pentru a se 

suprapune cât mai bine peste linia de țărm. Doar facem click pe butonul Selection , dăm click 
peste vertexul care se va muta și apoi click în noua locație (fără a ține butonul apăsat).
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Dacă am pierdut unele detalii ale conturului puteți adăuga unul sau mai multe vertex-uri pen-
tru a rezolva problema. Pentru aceasta activați butonul Edit vertex , dați click-dreapta pe linie, 
în locul unde vreți să inserați un vertex și selectați în meniul contextual Add. Odată inserați, 
aceștia pot fi mutați în poziția dorită.

Dacă avem prea multe vertex-uri dați click-dreapta pe vertex-ul care urmează a fi șters și 
selectați în meniul contextual Delete.

Copiere, lipire
Dacă doriți să ștergeți un poligon, selectăm poligonul, utilizând instrumentul Select by 

Point. Putem să selectăm mai multe obiecte pentru ștergere concomitent (Select byrectangle, … 
bypolygon).Odată ce avem selecțiile stabilite, apăsăm butonulDeletede la tastatură pentru a șterge 
obiectele.Obectul/obiectele selectate pot fi, de asemenea, copiate și apoi lipite în aceeași locație, în 
acest strat sau alt strat. Utilizați butoanele Copy/Paste .

6.2. Editarea în QGIS

6.2.1 Introducere
QGIS suportă module de digitizare și sprijină editarea elementelor spațiale într-o gamă largă de 

formate, inclusiv ESRI Shapefile, straturi PostGIS, și straturi GRASS.

6.2.2. Crearea unui nou set de date vectorial în format ESRI Shapefile
Pentru a crea un set de date shapefile: Layer→New→NewShapefile Layer…
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Vom crea un shapefile cu un Id și Nume. Alegem opțiunea Polygon la Type. În New attribute 
introducem la NameNume, la Type alegem Text data, iar la Width 25. Faceți click pe butonul Add 
to attributes list. Faceți click pe OK. În fereastra de dialog care apare stabiliți locația și numele 
noului strat de hartă și apăsați Save.

Noul strat este creat și încărcat în QGIS, doar că nu conține nici un element.
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6.2.3. Digitizarea unui poligon
Scopul nostru este de a digitiza unele obiecte din rasterul L-35-07-V_modified.tif.Încărcăm 

acest raster ca imagine de fundal, de pe care vom citi datele pentru digitizare. Pentru a începe 
digitizarea avem nevoie de permisiunea de a edita pentru noul strat: click dreapta pe temă și din 
meniul de tip pop-up alegem Toggle editing.

Înainte de a începe editarea, trebuie să ne asigurăm că bara de instrumente digitalizată este 
vizibilă. Dacă nu, facem click dreapta pe bara de instrumente și bifăm din meniul de tip pop-up 
Digitizing și Advanced Digitizing.

Unele din butoane de pe barele de instrumente sunt dezactivate (gri), pentru că QGISștie că se 
editează un strat poligon și nu ne permite să adăugăm obiecte greșite (linii sau puncte).

Să începem digitizarea:
1) Mărim o zonă din hartă în care există unlac.
2) Dacă nu suntem deja în modul Editare, facem click pe instrumentul Toggle editing.



84 INIȚIERE ÎN SIG
Ghid metodic

3) Facem click pe butonul Add feature  aflat pe bara de instrumente de digitalizare.
4) Pentru a digitiza, facem click cu butonul stânga al mouse-uluiși începem mișcarea de-a lungul 

liniei țărmului lacului. Facem clic la fiecare locație în care există o schimbare de direcție.

5) Dacă ajungem la marginea hărții și trebuie să vedeți mai mult din obiectul digitizat, țineți apă-
sată tasta Space și mișcați mouse-ul pentru a deplasa harta.

6) Dacă în timpul digitizării trebuie să mărim sau să micșorăm utilizați rotița mouse-ului.
7) Pentru a termina editarea lacului, efectuăm click-dreapta la punctul final. Acest lucru deschide 

o casetă de dialog în care vom introduce valorile atributelor definite (Id, Nume)
8) Introducem un număr de identificare și un nume pentru lac.

9) Pentru a salva modificările trebuie să oprim editarea, făcând clic pe instrumentul Toggle edi-
ting din bara de instrumente. O casetă de dialog apare și alegem Yes pentru a salva editările.

Lacul acum apare ca un poligon regulat și îl putem identifica și să-i vizualizăm atributele. Puteți 
continua digitizarea folosind instrumentul Toggle editing.

6.2.4. Editarea caracteristicilor
Instrumentele folosite pentru digitalizare se află în bara de instrumente de digitalizare și digita-

lizare avansată și permit adăugirea, ștergerea și modificarea poziției vertecșilor, astfel modificând 
obiectul propriu-zis.
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De la stânga la dreapta, instrumentele sunt:
1. Toggle editing – pornește/oprește editarea
2. Save edits – salvează editări
3. Add feature – adaugă element
4. Move feature(s) – mută element(e)
5. Node tools – instrumente pentru noduri
6. Delete selected – șterge elemente selectate
7. Cut Feature – taie obiectele selectate
8. Copy Feature – copiază obiectele selectate
9. Paste Feature – lipește obiectele selectate
10. Undo – anulează operația
11. Redo – repetă operația
12. Simplify feature – simplifică element
13. Add ring – adaugă inel
14. Add part – adaugă parte
15. Delete ring – șterge inel
16. Delete part – șterge parte
17. Reshape features – modifică elemente
18. Split features – divizează elemente
19. Merge selected features – combină elemente selectate
20. Merge attributes of selected features – combină atributele elementelor selectate
21. Rotate point symbols – rotește simbol punct.

Setarea toleranței snap

Înainte de a putea edita vertecși, avem nevoie de a seta toleranța de captare (snap). Aceasta este 
distanța pe care QGIS o utilizează pentru a „căuta”vertecși pe care încercăm să îi edităm atunci 
când facem click pe hartă. Dacă nu suntem în parametrii toleranței snapQGIS nu va găsi și selecta 
vertecși pentru editare. Toleranța este stabilită în unitatea de măsură a hărții. Dacă specificăm o 
toleranță prea mare, QGIS poate sări la un vertex greșit, mai ales dacă sunt un număr mare de 
vertecși în imediata apropiere. Dacă o setăm prea mică, nu va găsi nimic și va afișa o fereastră de 
avertisment în acest sens.

Pentru a stabili toleranța de captare, accesăm Settings→SnappingOptions.În dependență de 
unitatea de măsură a hărții adăugăm la Tolerance valoarea dorită.
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Editarea vertecșilor

Odată ce toleranța este stabilită, putem muta vertecși pentru a corecta greșelile pentru a se su-
prapune cât mai precis de-asupra liniei țărmului. Doar facem click pe butonul Node Tools, plasăm 
cursorul pe vertexul care se va muta și îl mișcăm în noua locație. Când se eliberează mouse-ul, 
vertexul este mutat iar forma poligonului se modifică.

Dacă am pierdut unele detalii ale conturului puteți adăuga unul sau mai mulți vertecși pentru a 
rezolva problema. Pentru aceasta dați dublu-click pe linie, în locul unde vreți să inserați un vertex. 
Odată ce am adăugat vertecșii de care avem nevoie, utilizăm instrumentul. Odată inserați, aceștia 
pot fi mutați în poziția dorită.

Dacă s-au acumulat prea mulți vertecși, faceți click pe vertexul care trebuie șters, și care își va 
schimba culoarea din roșu în albastru, și apăsați butonul Delete.

Copiere, decupare și lipire

Dacă doriți să ștergeți un poligon, selectăm poligonul, utilizând instrumentul Select Single 
Feature. Putem să selectăm mai multe obiecte pentru ștergere (Select by rectangle, …by polygon, 
…by freehand, …by radius).

Odată ce avem selecțiile stabilite, utilizăm instrumentul Delete Selected pentru a șterge obiec-
tele.

Instrumentul Cut Feature de pe bara de instrumente digitalizate poate fi utilizat pentru a șterge. 
Acesta șterge obiectele, dar le reține în memoria clipboard. Așa că dacă am tăiat un obiect pentru 
a-l șterge, putem apoi să utilizăm instrumentul Paste pentru a-l plasa în același loc (în acest strat 
sau în alt strat). Instrumentele copiere, decupare și lipire lucrează cu obiecte selectate în mod cu-
rent, având astfel optiunea de a opera cu mai multe obiecte la un moment dat.
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APLICAȚIE 7. LUCRUL CU TABELE DE ATRIBUTE

7.1. Despre shapefile
Esri Shapefile este un format popular de date geospațiale vectoriale. Formatul shapefile este ori-

entat pe geometrie: puncte, linii, poligoane, care pot reprezenta, respectiv, izvoare, râuri și lacuri. 
Un set de date poate conține elemente de o singură geometrie.

Fiecare item (geometrie) posedă atribute, care-l descriu, cum ar fi numele, temperatura sau 
altitudinea.

Formatul shapefile nu este bazat pe un singur fișier ci pe un set de fișiere, având același nume, 
dar extensii diferite.

Fișiere obligatorii sunt: *.shp — stochează elementele grafice, *.shx — fișier index pozițional
*.dbf — fișier ce conține atributele (dBase IV). Fișiere opționale sunt: *.prj — conține informații 

despre sistemul coordonate și proiecție (format well-known text), *.sbn, *.sbx, *.fbn, *.fbx, *.ain, 
*.aih, *.ixs, *.mxs, *.atx — fișiere index, *.shp.xml — fișier pentru metadate în format XML, *.cpg 
— fișier cu informații despre codificare caracterelor fișierelor .dbf.

7.2. Deschide tabel de atribute

7.2.1 gvSIG
Încărcați setul MDA_adm1.shp (Setați sistemul de referință pentru proiect și fișier EPSG:4326).
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Deschideți tabelul de atribute accesând butonul .

7.2.2 QGIS
Încărcați setul MDA_adm1.shp (Setați sistemul de referință pentru proiect și fișier EPSG:4326, 

click-dreapta pe setul de date în legendă - Set project CRS from layer).
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Deschideți tabelul de atribute: click-dreapta pe MDA_adm1 în legendă și alegeți din meniul 
apărut Open Attribute Table.
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7.3. Creare/Ștergere coloane

7.3.1 gvSIG
Din sesiunea anterioară, click-dreapta → Start editing. Deschideți tabelul de atribute accesând 

butonul Show attribute table of active layer.
Câmpurile (fields) sau coloanele (columns) în gvSIG pot fi gestionate cu instrumentul Manage 

fields (schema) care se lansează accesând Table→Manage fields.
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Aici puteți adăuga (Add), redenumi (Rename) și șterge câmpuri (coloane). Precum și să obțineți 
informații privitor la coloanele existente: tip, lungime, precizie. După efectuarea de schimbări nu 
uitați să salvați, pentru ca acestea să devină definitive.

7.3.2 QGIS
Click-dreapta în legendă pe strat. Open attribute table.

Toggle editing mode . Aceasta va activa butoanele New column și Delete column .

7.4. Inserare date
Inserarea de date noi în tabel se face de la tastatură în stare de editare. De asemenea, se poate 

utiliza un program de calcul tabelar cu suport de citire/scriere pentru fișiere *.dbf, cum ar fi Libre-
Office Calc, Apache OpenOffice Calc sau Microsoft Excel (până la versiunea 2003 inclusiv)

Pentru aceasta, lansați LibreOffice Calc (sau altul), deschideți fișierul DBF.
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Veți fi întrebat de codificare, alegeți din listă (pentru limba română aveți de ales între una dintre 
codificările est-europene și Unicode (UTF-8).

Acum puteți adăuga/șterge/redenumi sau schimba tipul de date pentru câmpuri, insera date 
noi sau corecta pe cele existente. Fiți atenți! nu ștergeți sau adăugați rânduri (înscrisuri) noi în 
tabel - aceasta va altera integritatea setului de date Shapefile, care va deveni inutil. Pentru acest fel 
de manipulări folosiți softuri GIS.
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APLICAȚIE 8. GEOPROCESARE DATE VECTORIALE

8.1. Geoprocesare vectori în gvSIG

8.1.1. Accesare instrumente
Pentru operații geometrice asupra vectorilor în gvSIG pot fi utilizate două boxe de instrumente:
•	 Geoprocessing tools ( )
•	 SEXTANTE ( ).
Se accesează Geoprocessing tools... din meniul View .

8.1.2.a Funcționalitățile Geoprocessing tools
Funcționalitățile toolbox-ului pot fi accesate din arborele ierarhic din stânga ferestrei.

Întreaga suită de funcții este împărțită în 6 categorii:
Proximity

Overlay

Computational geometry

Aggregation
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Geoprocessing tools that transform data

Data conversion

8.1.2.b Funcționalitățile SEXTANTE
SEXTANTE este o bibliotecă de analiză spațială a datelor și un cadru de geoprocesare robust. 

În prezent are două versiuni, una scrisă în Java și alta în limbaj Python, ceea ce permite să fie in-
tegrată într-un număr mare de aplicații GIS.

Toolbox (cutia cu instrumente) este elementul principal al interfeței SEXTANTE. Acesta pre-
zintă lista tuturor algoritmilor disponibili, grupați în blocuri, și este punctul de acces pentru a le 
rula fie proces unic fie pe un ser de documente.
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8.1.2.1 Statistici de bază / Basic Statistics
Funcția permite calcularea unor parametri statistici pentru un șir de date.
Pașii ce trebuie urmați sunt următorii:
Din meniul SEXTANTE→Algorithms→Tools for vector layers→Basic statistics;
În fereastra nou deschisă se indică fișierele și coloana pentru care se dorește calcularea parame-

trilor statistici, urmat de click pe butonul OK.

Rezultatul trebuie să arate ca în imaginea de mai jos.

8.1.2.2 Zone tampon (Buffer (s))
Prin intermediul acestei funcții se poate realiza o zonă-tampon în jurul unei entități spațiale 

în funcție de o distanță specificată de utilizator sau a unei distanțe existente în tabela de atribute a 
entității spațiale respective.

Pașii ce trebuie urmați sunt următorii:
Accesăm View→ Geoprocesses Toolbox→Geoprocesses→Analysis→Proximity→Buffer.
În fereastra nou deschisă se indică fișierul pentru care se dorește crearea zonei-tampon, distanța 

și locul unde se dorește a fi salvat noul fișier, urmat de click pe butonul OK. Tot în această fereas-
tră avem posibilitatea de a seta distanța manual, sau de a fi preluată dintr-un tabel de atribute. De 
asemenea, dacă se bifează opțiunea Dissolve entities, rezultatul va consta într-un singur poligon 
pentru toate înregistrările din fișier, în caz contrar va fi creat câte un poligon pentru fiecare enti-
tate spațială.
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Rezultatul trebuie să arate ca în imaginile de mai jos.

Figură 3: Fără opțiunea Dissolve
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Figură 2: Cu opțiunea Dissolve

Funcția poate fi aplicată atât entităților vectoriale de tip punct cât și pentru cele de tip linie și 
poligon.

8.1.2.3 Decupare / Clip
Această funcție permite ca entitățile spațiale aparținând unei clase ce se intersectează cu 

entitățile spațiale ale altei clase să poată fi exportate într-un fișier nou. Fișierul după care se dorește 
să se facă tăierea trebuie să fie de tip poligon. În cazul de față s-a folosit un fișier de tip linie.
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Se procedează în felul următor:
View→ Geoprocesses Toolbox→Geoprocesses→Overlay→Clip.
În fereastra nou deschisă se indică fișierele dorite, urmat de click pe butonul OK.

Rezultatul trebuie să arate ca în imaginea de mai jos.

Funcția poate fi aplicată atât entităților vectoriale de tip punct cât și pentru cele de tip linie și 
poligon.

8.1.2.4 Dizolvare / Dissolve
Această funcție unește entitățile spațiale aparținând unei clase în funcție de anumite atribute. 

Așadar toate entitățile ce au atribute comune vor fi unite într-una singură.
Efectuați următorii pași:
View→ Geoprocesses Toolbox→Geoprocesses→Aggregation→Dissolve.
În fereastra nou deschisă se indică fișierul dorit, câmpul după care să se facă unirea, urmat de 

click pe butonul OK.
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Rezultatul trebuie să arate ca în imaginea de mai jos.

Inițial După dizolvare

8.2. Geoprocesare vectori în QGIS utilizînd plugin-ul fTools

8.2.1. Instalare
Începând cu versiunea QGIS 1.6 extensia este implementată în configurația de bază.

8.2.2. Funcționalitățile plugin-ului fTools
Funcționalitățile plugin-ului pot fi accesate din bara de meniuri dându-se click pe tab-ul Vec-

tor.
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Întreaga suită de funcții este împărțită în 5 mari categorii:
Analysis Tools

Research Tools

Geoprocessing Tools

Geometry Tools
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Data Management Tools

8.2.2.1 Statistici de bază / Basic Statistics
Funcția permite calcularea unor parametri statistici pentru un șir de date cum ar fi: Media arit-

metică, Deviația Medie Pătratică, Suma, Mediana, Coeficientul de Variație, etc.
Pașii ce trebuie urmați sunt următorii:
Din meniul Vector→Analysis Tools→Basic statistics;
În fereastra nou deschisă se indică fișierele și coloana pentru care se dorește calcularea parame-

trilor statistici, urmat de click pe butonul OK. Rezultatul trebuie să arate ca în imaginea de mai jos.

8.2.2.2 Zone tampon (Buffer (s))
Prin intermediul acestei funcții se poate realiza o zonă-tampon în jurul unei entități spațiale 

în funcție de o distanță specificată de utilizator sau a unei distanțe existente în tabela de atribute a 
entității spațiale respective.

Efectuați următorii pași:
Din meniul Vector→Geoprocessing Tools→Buffer(s).
În fereastra nou deschisă se indică fișierul pentru care se dorește crearea zonei-tampon, distanța 

și locul unde se dorește a fi salvat noul fișier, urmat de click pe butonul OK. Tot în această fereas-
tră avem posibilitatea de a seta distanța manual, sau de a fi preluată dintr-un tabel de atribute. De 
asemenea, dacă se bifează opțiunea Dissolve buffer results rezultatul va consta într-un singur po-
ligon pentru toate înregistrările din fișier, în caz contrar va fi creat câte un poligon pentru fiecare 
entitate spațială.
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Rezultatul trebuie să arate ca în imaginile de mai jos.

Figură 3: Fără opțiunea Dissolve
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Figură 4: Cu opțiunea Dissolve

Funcția poate fi aplicată atât entităților vectoriale de tip punct cât și pentru cele de tip linie și 
poligon.

8.2.2.3 Decupare / Clip
Această funcție permite ca entitățile spațiale aparținând unei clase ce se intersectează cu 

entitățile spațiale ale altei clase să poată fi exportate într-un fișier nou. Fișierul după care se dorește 
să se facă tăierea trebuie să fie de tip poligon. În cazul de față s-a folosit un fișier de tip linie.
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Se procedează în felul următor:
Din meniul Vector→Geoprocessing Tools→Clip.
În fereastra nou deschisă se indică fișierele dorite, urmat de click pe butonul OK.

Rezultatul trebuie să arate ca în imaginea de mai jos.

Funcția poate fi aplicată atât entităților vectoriale de tip punct cât și pentru cele de tip linie și 
poligon.

8.2.2.4 Dizolvare / Dissolve
Această funcție unește entitățile spațiale aparținând unei clase în funcție de anumite atribute. 

Așadar toate entitățile ce au atribute comune vor fi unite într-una singură.
Efectuați urmatorii pași:
Din meniul Vector→Geoprocessing Tools→Dissolve.
În fereastra deschisă se indică fișierul dorit, câmpul după care să se facă unirea, urmat de click 

pe butonul OK.
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Rezultatul trebuie să arate ca în imaginea de mai jos.

Până la dizolvare După dizolvare
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APLICAȚIE 9. REPROIECTARE DATE RASTER ȘI VECTOR

Sistemele de coordonate pot fi de două tipuri:
1. Sisteme de Coordonate Geografice, care utilizează coordonate geografice (latitudinea și lon-

gitudinea). Aceste sisteme nu folosesc o proiecție. Ca și unitate de măsură este utilizat gradul.
2. Sisteme de Coordonate Carteziene, care utilizează coordonatele X și Y pentru localizarea 

obiectelor. Aceste sisteme de coordonate utilizează proiecții cartografice. Unitatea de măsu-
ră utilizată de acestea este metrul.

SIG-urile moderne suportă multiple sisteme de coordonate și transformări între sistemele de 
coordonate. Unele SIG-uri suportă, de asemenea, transformarea „în zbor” a coordonatelor dintr-
un sistem în altul. gvSIG suportă parțial această funcție, iar QGIS – începând cu versiunea 1.7. 
Reproiectarea „în zbor” permite încărcarea în același proiect a unor seturi de date având sisteme 
de proiecții diferite, fără a afecta datele propriu-zise. Reproiectarea definitivă presupune transfor-
marea datelor inițiale și înregistrarea rezultatului sub forma unui nou set de date.

9.1. Reproiectare hărți (în zbor – on the fly)

9.1.1 gvSIG
Setarea sistemului de coordonate pentru View
1. Deschideți fereastra View properties.
2. Accesați butonul care deschide fereastra pentru a alege sistemul de coordonate .
3. Alegeți sistemul de coordonate dorit.
4. Confirmați, apăsând ОК.

Pentru alegerea SC se oferă o listă de opțiuni:
•	 Recent – sistemele de coordonate utilizate recent.
•	 EPSG – sistemele de coordonate definite de Comitetul pentru Geomatică al Asociației 

Internaționale a Producătorilor de Petrol și Gaze.
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•	 ESRI – sisteme de coordonate definite de compania ESRI (Environmental Systems Research 
Institute).

•	 IAU2000 – sisteme de coordonate definite de Uniunea Astronomică Internațională.
•	 User-defined – sisteme de coordonate definite de utilizator.
Căutarea se poate realiza după:
•	 Cod
•	 Nume
•	 Teritoriu.
Selectarea Sistemului de Coordonate
1. Alegeți Type
2. Alegeți Criteria
3. Inserați interogarea, apăsați Search
4. Selectați sistemul de coordonate
5. Apăsați OK.
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Figură 1: EPSG:4326 - Lat/Long WGS 84

Figură 2: EPSG:54009 - World Mollweide



109INIȚIERE ÎN SIG
Ghid metodic

Figură 3: EPSG:54030 – World Robinson

Verificați pe rând toate aceste proiecții.

9.1.2 QGIS
Setarea sistemului de coordonate pentru fereastra de hartă
1. Încărcați stratele de hartă (cntry98.shp și latlong.shp)
2. Din bara de stare, accesați butonul care deschide fereastra pentru a alege sistemul de coordo-

nate .
3. Alegeți sistemul de coordonate dorit. Bifați „enable on the fly CRS transformations”.
4. Confirmați, apăsând ОК.



110 INIȚIERE ÎN SIG
Ghid metodic

În cazul când sistemul de coordonate dorit lipsește în listă (și este cazul nostru), este necesar să 
definim noi sisteme de coordonate în QGIS. Pentru aceasta accesați în meniul Settings:

Apăsați butonul Run , inserați denumirea și parametrii sistemului de coordonate definit în 
format PROJ4 și salvați accesând .

Definițiile pentru câteva proiecții clasice sunt:
1. World Robinson
+proj=robin +lon_0=0 +x_0=0 +y_0=0 +ellps=WGS84 +datum=WGS84 +units=m +no_defs
2. World Mollweide
+proj=moll +lon_0=0 +x_0=0 +y_0=0 +ellps=WGS84 +datum=WGS84 +units=m +no_defs 
3. Sphere Van der Grinten I
+proj=vandg +lon_0=0 +x_0=0 +y_0=0 +R_A +a=6371000 +b=6371000 +units=m +no_defs
Pentru alte sisteme căutați pe http://spatialreference.org/.

OK.
Acum noul sistem de coordonate este disponibil în fereastra Project Properties, fila Coordinate 

Reference Systems la categoria User Defined Coordinate Systems.
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Figură 1: EPSG:4326 - Lat/Long WGS 84

Figură 2: EPSG:54009 - World Mollweide
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Figură 3: EPSG:54030 – World Robinson

Verificați pe rând toate aceste proiecții.

9.2. Reproiectare definitivă vectori

9.2.1 gvSIG
Lansați gvSIG, setați sistemul de coordonate pentru proiect EPSG:4326, încărcați stratul MDA_

adm1.shp (EPSG:4326)
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Lansați Geoprocess toolbox→Data conversion→Reproject. Setați opțiunile de transformare: 
Target projection și Output cover. Ok.

Fișierul nou creat și proiectat în sistem EPSG:32635 (WGS 84 / UTM zone 35N).

9.2.2 QGIS
Lansați QGIS, setați sistemul de coordonate pentru proiect EPSG:4326, încărcați stratul MDA_

adm1.shp (EPSG:4326).
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Din meniul Vector (fTools, este posibil să trebuiască să reinstalați plugin-ul pentru a avea acest 
instrument), lansați Export to new projection.

Setați opțiunile de transformare: Output spatial reference system și Output Shapefile. OK.

Fișierul nou creat și proiectat în sistem EPSG:32635 (WGS84_UTM_35N).
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9.3. Reproiectare definitivă raster

9.3.1 gvSIG
Lansați gvSIG, setați sistemul de coordonate pentru proiect EPSG:32635, încărcați rasterul 

dem.tif (EPSG:32635).

Lansați Reproject layer din bara de instrumente raster
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Setați opțiunile de transformare: Target projection și Output cover (Create file). Accept.

Save .Fișierul nou creat și proiectat în sistem EPSG:28465 (Pulkovo 1942 / Gauss-Kruger 5N).
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9.3.2 QGIS
Lansați QGIS, setați sistemul de coordonate pentru proiect EPSG:32635, încărcați rasterul 

dem.tif (EPSG:32635).

Din meniul Raster, lansați Projections→Warp (Reproject).
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Setați opțiunile de transformare: Output file, Target CRS, Resampling method, No data values. 
OK.

Fișierul nou creat și proiectat în sistem EPSG:28465 (Pulkovo 1942 / Gauss-Kruger 5N).
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APLICAȚIE 10. MOZAICARE ȘI DECUPARE RASTERE

10.1. Mozaicare rastere

10.1.1 Mozaicare rastere în gvSIG
Încărcați foile de hartă topografică.

Lansați instrumentul pentru mozaicare:



120 INIȚIERE ÎN SIG
Ghid metodic

Setați parametrii de intrare și ieșire.

Pentru rasterele cu o singură bandă poate fi utilizat și instrumentul GRASS GIS r.patch, accesat 
prin intermediul interfeței SEXTANTE 
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Rezultatul trebuie să arate aproximativ așa:
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10.1.2 Mozaicare raster în QGIS
Funcționalitatea de bază raster în QGIS este asigurată de plugin-ul GdalTools, disponibil în 

meniul Raster. Încărcați fișiere raster: click→Add Raster Layer.

Aveți acum încărcate 2 foi de hartă topografică. Dați click-dreapta pe una dintre ele în legendă 
și apoi click Properties.
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În dialogul Properties puteți examina detalii despre imagine în filele General și Metadata. Fiece 
raster poate fi afișat utilizând până la 3 benzi ale acesteia, pentru canalele RGB (Red Green Blue).

Dați click pe OK pentru a reveni în fereastra principală QGIS. Pentru crearea unui mozaic pen-
tru imaginile încărcate: click Raster→Miscellaneous→Merge.

Setați fișierele de intrare (Select...) și de ieșire (Select...), No data value și apăsați OK.
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Imaginile individuale vor fi unite într-o singură imagine „mozaic”.

10.2. Decupare rastere

10.2.1 Decupare raster în gvSIG

10.2.1.1 Decupare după extindere
Încărcați rasterul mosaic2.img. Accesați Export image→Clipping...

Accesați butonul Select from view  și descrieți cu ajutorul cursorului limita selecției. Coor-
donatele X, Y ale colțurilor extreme (sus-stânga și jos-dreapta) vor fi încărcate în dialog.
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Rezultatul va fi încărcat în vedere.

10.2.1.2 Decupare după mască vectorială
Încărcați rasterul mosaic2.img. Încărcați stratul poligonal mască pentru decupare.
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Lansați SEXTANTE→Crop grid with polygon layer.

Setați parametrii de intrare și ieșire. OK.
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10.2.2 Decupare raster QGIS
Pentru decuparea unui raster click Raster→Extraction→Clipper.

În dialogul Clipper setați stratul care va fi decupat (Input file), setul de date decupat (Output 
file). Există două posibilități de decupare: după extindere (Extent) sau după o mască vectorială 
(Mask layer). Pentru a decupa după extindere, selectați extindere inserând pe hartă un drept-
unghi. Coordonatele colțurilor acestuia vor fi citite în căsuțele prevăzute pentru coordonate în 
dialogul Clipper. Apăsați OK.
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Pentru a decupa după mască activați opțiunea Mask layer.

Apăsați OK. Rezultatele vor arăta aproximativ așa:
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APLICAȚIE 11. RASTER CALCULATOR

11.1. Raster Calculator

11.1.1 gvSIG
Calculatorul pe raster permite efectuarea de operații matematice asupra celulelor de raster. 

Operațiile pot fi:
Matematice (+, -, *, /)
Trigonometrice (sin, cos, tan, asin, acos, atan)
De comparație (<, >, =, <=, >=)
Logice (AND, OR)
Pentru a efectua calcule pe rastere, acestea trebuie să fie încărcate în QGIS. Raster calculator 

este accesat din bara de instrumente raster:

Operații simple
În acest exercițiu vom utiliza un Model Numeric al Terenului încărcat în gvSIG. MNT conține 

valori ale altitudinii reliefului reprezentată în metri. Să admitem că vrem să reprezentăm altitudi-
nea în centimetri. Pentru aceasta:

Lansați Raster Calculator
Dublu-click pe Band1 lista benzilor raster
Dublu-click pe semnul înmulțirii (*)
În boxa expresiei tastați 100 (centimetri în 1 metru)
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Aceasta ne va da expresia: b1 * 100.

Click Apply.  Rezultatul va fi încărcat în proiect.

Interogarea rasterului și extragerea valorilor într-un fișier nou
De extras sectoarele de teren cu altitudinea mai mare de 200 m. Pentru aceasta:
Încărcați MNT
Inserați expresia b1 > 200
Apăsați Apply.
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Rasterul creat va conține două valori: 0 - pentru celulele MNT care nu corespund expresiei și 
1 - pentru cele care corespund cu aceasta.

11.1.2 QGIS
Calculatorul pe raster permite efectuarea de operații matematice asupra celulelor de raster. 

Operațiile pot fi:
Matematice (+, -, *, /)
Trigonometrice (sin, cos, tan, asin, acos, atan)
De comparație (<, >, =, <=, >=)
Logice (AND, OR)
Pentru a efectua calcule pe rastere, acestea trebuie să fie încărcate în QGIS. Raster calculator 

este accesat din meniul Raster:
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Operații simple
În acest exercițiu vom utiliza un Model Numeric al Terenului încărcat în QGIS. MNT conține 

valori ale altitudinii reliefului reprezentată în metri. Să admitem că vrem să reprezentăm altitudi-
nea în centimetri. Pentru aceasta:

Lansați Raster Calculator
Dublu-click pe mnat@1 în lista benzilor raster
Dublu-click pe semnul înmulțirii (*)
În boxa expresiei (Raster calculator expression) tastați 100 (centimetri în 1 metru)
Aceasta ne va da expresia: mnat@1 * 100. Pentru a finaliza operația, specificați un nume pentru 

rezultat.

Click OK.  Rezultatul va fi încărcat în proiect.
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Interogarea rasterului și extragerea valorilor într-un fișier nou
De extras sectoarele de teren cu altitudinea mai mare de 200 m. Pentru aceasta:
Încărcați MNT
Inserați expresia mnat@1 > 200
Setați fișierul de ieșire
Apăsați OK.
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Rasterul creat va conține două valori: 0 - pentru celulele MNT care nu corespund expresiei și 
1 - pentru cele care corespund cu aceasta.
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APLICAȚIE 12. INTERPOLARE SUPRAFEȚE (CREARE MNT)

12.1. gvSIG
Încărcați setul de date curbe de nivel în gvSIG.

Acționați SEXTANTE→Rasterization and interpolation→Rasterize vector layers.
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Setați Vector layer și Field (câmpul Altitudine), fișierul de ieșire, extinderea și rezoluția.

OK. Fișierul raster încărcat va conține valori pentru curbele de nivel și NoData pentru spațiul 
dintre izohipse.



137INIȚIERE ÎN SIG
Ghid metodic

Accesați SEXTANTE→Basic tools for raster layers→Void filling.

Setați stratul curbe raster la Inputs.
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OK. Rezultatul va arăta aproximativ așa.

Pentru o mai bună vizualizare vom crea un strat umbrire a reliefului, pe care îl vom folosi pen-
tru draparea elevației. SEXTANTE→Visibility and ligghting→Shaded relief
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Setați datele de intrare, extinderea și rezoluția fișierului de ieșire.

OK. Pentru a obține efectul 3D trebuie să setăm transparență pentru stratul elevație (click 
dreapta→Transparency→Activate).
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12.2. QGIS

12.2.1 Interpolare IDW în QGIS
Încărcați setul de date de tip puncte: Add Vector Layer, selectați annual_precipitation.shp. 

Deschideți tabelul de atribute pentru a observa datele care vor fi utilizate pentru interpolare. Veți 
putea vedea coloana numită „precip” - cantitatea de precipitații în milimetri. Închideți tabelul de 
atribute.
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Pentru interpolare lansați din meniul Raster→Interpolation→Interpolation.

În fereastra plugin-ului setați: Vector layers, Interpolation attribute, Add, Vector layer type, 
Interpolation method, Cellsize și Output file.

OK.
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12.2.2 Interpolare TIN în QGIS
Încărcați setul de date de tip puncte: Add Vector Layer, selectați annual_precipitation.shp. 

Deschideți tabelul de atribute pentru a observa datele care vor fi utilizate pentru interpolare. Veți 
putea vedea coloana numită „precip” - cantitatea de precipitații în milimetri. Închideți tabelul de 
atribute.
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Pentru interpolare lansați din meniul Raster→Interpolation→Interpolation.

În fereastra plugin-ului setați: Vector layers, Interpolation attribute, Add, Vector layer type, 
Interpolation method, Cellsize și Output file.

OK.

12.3. GRASS GIS
GRASS GIS conține mai multe module de interpolare, unele dintre acestea lucrează doar pe 

puncte, altele pe raster și doar unele - direct pe curbe.
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12.3.1 r.surf.idw
r.surf.idw (și r.surf.idw2) realizează interpolare Inverse Distance Weighting (IDW), utilizând 

n cele mai apropiate puncte pentru a calcula valoarea unei celule, punctele mai apropiate având o 
pondere mai mare. Metoda IDW nu este foarte potrivită pentru lucrul cu curbe de nivel, dar este 
simplă și accesibilă începătorilor.

Figură 13: r.surf.idw2 cu npoints=12

12.3.2 v.surf.bspline
Modulul v.surf.bspline poate fi acceptabil, dar necesită de a converti curbele de nivel în puncte. 

Pentru aceasta poate servi modulul v.to.points. Este predestinat pentru interpolarea unor seturi 
de date voluminoase LIDAR.

Figură 14: Interpolare biliniară cu v.surf.vspline utilizând parametrii predefiniți

12.3.3 v.surf.rst
Modulul v.surf.rst aplică interpolarea Regularized Spline with Tension. Nu garantează că 

suprafața obținută va atinge exact toate punctele inițiale, însă minimizează diferența generală pen-
tru toate punctele din hartă.
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Figură 3: v.surf.rst utilizând parametrii predefiniți

12.3.4 r.surf.contour
Modulul GRASS r.surf.contour este construit special pentru convertirea curbelor de nivel în 

MNT și de obicei face acest lucru destul de bine.

Figură 4: r.surf.contour
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APLICAȚIE 13. ANALIZA RELIEFULUI

13.1. Analiza reliefului în gvSIG
Instrumentele pentru analiza reliefului pot fi găsite în boxa de instrumente SEXTANTE. Pentru 

harta pantelor selectați:  SEXTANTE→Geomorphometry and terrain analysis→Slope.

Setați datele de intrare, metoda, unitățile de măsură, fișierul de ieșire (opțional).

De asemenea, extinderea și rezoluția fișierului rezultat.
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Rezultatul se încarcă în program.
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Pentru expunerea versanților selectați: SEXTANTE→Geomorphometry and terrain analysis→ 
Aspect.

Setați datele de intrare, metoda, unitățile de măsură, fișierul de ieșire (opțional).

De asemenea, extinderea și rezoluția fișierului rezultat.
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Rezultatul se încarcă în program.

13.2. Analiza reliefului în QGIS
În QGIS există câteva instrumente specializate în analiza elementară a reliefului. Plugin-ul Ter-

rain analysis, DEM (Terrain models) din GDAL Tools, interfața către GRASS GIS (GRASS Tools), 
interfața SEXTANTE către SAGA GIS.

Plugin-ul Terrain analysis



150 INIȚIERE ÎN SIG
Ghid metodic

Figură 2: DEM (Terrain models) din GDAL Tools

GRASS Toolbox

În acest exercițiu vom folosi Plugin-ul Terrain analysis. Raster→Terrain analysis.
Pentru crearea hărții pantelor lansați Raster→Terrain analysis→Slope. Setați datele de intrare, 

datele de ieșire și apăsați OK.
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Rezultatul va fi încărcat în QGIS.

Pentru crearea hărții expoziției versanților lansați Raster→Terrain analysis→Aspect. Setați date-
le de intrare, datele de ieșire și apăsați OK.
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Rezultatul va fi încărcat în QGIS.
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APLICAȚIE 14. GENERAREA AUTOMATĂ A REȚELEI ȘI BAZINELOR 
HIDROGRAFICE GVSIG/QGIS PRIN INTERMEDIUL SEXTANTE

14.1. Eliminarea depresiunior din Modelul Numeric de 
Elevație (MDE, MNT)

Încărcați MNT. Procesul permite corectarea iregularităților MNT, în special depresiunile, care 
împiedică realizarea rețelei de drenaj, mai ales dacă acestea nu sunt reale. În acest scop, accesați 
instrumentul Sink filling din SEXTANTE Toolbox.

Setați fișierele de intrare și ieșire. OK.
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14.2. Calcularea acumulării scurgerii
Operația acumulării scurgerii realizează cumularea numărului de pixeli care drenează în mod 

natural către o gură de vărsare. Operația poate fi folosită pentru a găsi modelul de drenaj a terito-
riului.

Setați fișierele de intrare și ieșire, metoda de calcul, extinderea și rezoluția fișierului de ieșire. 
OK.
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Rezultatul va arăta aproximativ astfel:

Figură 1: Harta acumulării scurgerii
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14.3. Calcularea rețelei de drenaj
Extragerea rețelei hidrografice presupune existența MDE preprocesat, a hărții acumulării scur-

gerii și a pragului de declanșare a scurgerii (Threshold). Pragul declanșării scurgerii va fi citit de 
pe harta acumulării scurgerii utilizând instrumentul Information .

Setați parametrii de intrare și ieșire.
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OK.
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14.4. Calculare bazine de hidrografice

Setați parametrii de intrare și ieșire.
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Rezultatul va arăta aproximativ așa:
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14.5. Vectorizare strat raster Bazine hidrografice
Deseori, în  cadrul SIG, pentru diverse calcule și analize este de preferat formatul vectorial. 

Pentru aceasta vom converti Bazinele hidrografice din format raster în format vector. Lansați in-
strumentul Vectorize raster layer (polygons).
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14.6. Calculare proprietăți geometrice pentru poligoane
Lansați instrumentul Geometric properties of polygons.
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Setați fișierul polygon de intrare. OK

Deschideți tabelul de atribute pentru a vizualiza rezultatul.
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APLICAȚIE 15. AȘEZARE ÎN PAGINĂ

Adeseori apare necesitatea de a crea hărți pentru imprimare sau publicare. QGIS dispune de un 
instrument robust numit Print Composer care permite împachetarea straturilor de hartă raster și 
vector și crearea în baza lor a unor așezări în pagină.

În acest exercițiu vom crea o hartă a Republicii Moldova.
Adăugați toate stratele de hartă pe care vreți să le adăugați: MNT, umbrire relief, râuri, lacuri, 

hotarul de stat și setați simbologia stratelor după cum vreți să apară în harta finală.
În meniul File accesați New Print Composer.
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Se va deschide fereastra Composer 1 compusă din 3 părți: bara de meniuri, foaia de hartă și 
controalele elementelor de hartă.

Setați dimensiunile, orientarea și rezoluția foii de hartă din foaia Composition.

Faceți click pe butonul Add new map  din bara de instrumente sau meniul Layout. Apăsați 
butonul de stânga a mouse-ului și descrieți un dreptunghi pe pagină acolo unde vreți să apară 
cadrul hărții.
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Ajustați scara hărți și centrați cadrul hărții, faceți click pe Layout→Move Content. Dați click în 
interiorul cadrului hărții și deplasați harta în poziția dorită.
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Pentru redimensionare puteți utiliza rotița mouse-ului. Dacă însă doriți precizie, dați click pe 
fila Item Properties (subfila Map) și ajustați valoarea Scale.

Din subfila General options setați caracteristicile cadrului hărții, fundalului, inclusiv 
transparența.
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Adăugați Indicatorul/Săgeata Nord la hartă. Dați click pe Layout→Add Image.

Ținând apăsat butonul de stânga al mouse-ului, descrieți un dreptunghi pe hartă, în poziția 
unde vreți să plasați săgeata. Dați click pe fila Item Properties și selectați imaginea dorită. Dați 
click pe subfila General Options.
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Ajustați transparența, culoarea cadrului indicatorului, culoarea de fundal etc.

Adăugați scara grafică. Dați click pe Layout→Add Scalebar.
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Din fila Item Properties selectați stilul care corespunde exigențelor hărții.

Setați, de asemenea, transparența, din fila General Options.
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Adăugați de asemenea Legenda hărții. Dați click pe Layout→Add Legend.

Dacă aveți adăugate la hartă mai multe straturi, atunci caseta legendei inserate trebuie să fie 
destul de mare.
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Dați click pe fila Item Properties și selectați stratul pe care nu vreți să-l aveți în legendă, apoi 
apăsați butonul ”-”.

Ajustați de asemenea transparența și font-urile utilizate în legendă din fila General Options.



172 INIȚIERE ÎN SIG
Ghid metodic

În sfârșit vom eticheta harta. Dați click pe Layout→Add Label.

Dați click pe hartă și descrieți un dreptunghi în locul unde vreți să plasați eticheta hărții. În fila 
Item Properties inserați textul. Dați click pe butonul Font pentru a ajusta caracterul utilizat.

Harta finală poate fi exportată ca imagine, fișier PDF sau SVG. Exportați harta în PDF. 
File→export to PDF
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Harta exportată poate fi deschisă cu ajutorul unui vizualizator de documente PDF pentru vizu-
alizare sau imprimare, sau editată cu ajutorul unui editor grafic (GIMP, Inkscape).
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